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DATA ANALYSIS IN SPSS  
POINT AND CLICK 

www.ats.ucla.edu/stat/seminars/special/SPSS_analysis.pdf 



 Continuous, Categorical, and Ordinal variables 
 Descriptive Statistics – Summaries of single variables 
 Hypothesis Testing –Making inferences with statistics 
 T-tests – comparing continuous means between 2 groups 
 ANOVA and linear regression – comparing/predicting means 

among/using several variables 
 Chi-square – comparing proportions among categories 
 Logistic regression – predicting a binary (yes/no) outcome 

 

TODAY’S SEMINAR 



 Continuous  
 numerical values meaningful  
 usually a measurement 
 e.g. age, height, blood pressure 
 SPSS calls these “scale” variables 

CONTINUOUS, CATEGORICAL AND 
ORDINAL VARIABLES 



 Categorical  
 numerical values, typically arbitrary labels, representing membership 

to a category 
 e.g. gender, occupation, hospital 
 SPSS calls these “nominal” variables 
 Value labels very useful 

 

CONTINUOUS, CATEGORICAL AND 
ORDINAL VARIABLES 



 Ordinal  
 numerical values denote relative rank, but lack clear absolute 

meaning 
 e.g. Pain scale (1-10), Likert scales, income bracket  
 SPSS calls these “ordinal” variables 

 

CONTINUOUS, CATEGORICAL AND 
ORDINAL VARIABLES 



 In Variable View, can specify variable types in “Measure” 
column 
 SPSS will guess types when you load data  
 Some commands expect certain variables types to be used 
 helpful to have types specified beforehand 

 

SPSS WORKS A BIT SMOOTHER IF YOU 
SPECIFY YOUR VARIABLE TYPES 



SPSS WORKS A BIT SMOOTHER IF YOU 
SPECIFY YOUR VARIABLE TYPES 



 Summarize them dif ferently 
 Continuous = means, standard deviations, quantiles (e.g. quartiles) 
 Categorical = frequencies 

 When analyzed as an outcome, the variable’s type determines 
the appropriate analysis 
 Continuous = t-test, ANOVA, regression 
 Categorical = chi-square test of independence, logistic regression 

 Ordinal variables can be analyzed both ways 
 treating them as continuous is controversial  
 Safer to analyze as a categorical variable, usually 
 Fewer assumptions 

 Also have their own set of analyses (ordinal logistic regression) 

WE ANALYZE CONTINUOUS AND 
CATEGORICAL VARIABLES DIFFERENTLY 



 Descriptive statistics provide summaries of the characteristics 
of the sample 
 NOT used to infer relationships between variables, so no p-values 

 

 
 

DESCRIPTIVE STATISTICS – CHARACTERIZING 
THE SAMPLE 



 Continuous variables 
 Use Analyze -> Descriptive Statistics -> Descriptives 
 Calculates mean, standard deviation, and minimum and maximum 

 
 

 

 
 

DESCRIPTIVE STATISTICS – CONTINUOUS 
VARIABLES 



 Continuous variables 
 Use Analyze -> Descriptive Statistics -> Frequencies 
 Proportion of sample within each category 

 
 

 
 

DESCRIPTIVE STATISTICS – CATEGORICAL 
AND ORDINAL VARIABLES 



 We assess the truthfulness of our research hypothesis using 
statistics 

 Typically we are interested in showing: 
 Groups are different 
 One variable predicts another variable 

HYPOTHESIS TESTING 



 Formally: 
 We propose an uninteresting (null) hypothesis 
 Groups are not different 
 This variable does not predict that variable 

 We calculate the probability of the outcome if we assume the null 
hypothesis is true 
 This probability = p-value 

 Assess the null hypothesis in light of this probability 
 A small probability implies the outcome is VERY UNLIKELY if the null 

hypothesis is true, so we reject the null hypothesis 
 We thus conclude that the interesting, alternative hypothesis is supported 

HYPOTHESIS TESTING 



 Suppose a man on a street challenges you to a game of dice 
 Highest sum of 2 dice wins 
 First roll -- You: 6, He: 12 
 Second roll – You: 9, He: 12 

 You immediately hypothesize he’s cheating with a loaded dice 
 Let’s test it 

 

HYPOTHESIS TEST EXAMPLE 



 1.  Propose the uninteresting null hypothesis: 
 His pair of dice are fair. 

 2.  Calculate probability of outcome if we assume null 
hypothesis is true: 
 If his dice are fair, the probability of rolling 12 and 12 is 1/36*1/36 

= 0.00077 
 We don’t know the probability of rolling 12 and 12 with a loaded pair of 

dice, but we do with a fair pair of dice 
 This is why we test the null, not the alternative 

 3.  Assess null hypothesis in light of this probability (p-value) 
 Since this outcome is so rare with a fair pair of dice, we reject the 

null hypothesis that he is using a fair pair of dice 
 Typically, a threshold p-value of 0.05 is used for rejection of the null 

 We thus conclude he is cheating 
 The alternative hypothesis 

 

HYPOTHESIS TEST EXAMPLE 



 1.  Propose the uninteresting null  hypothesis: 
 This drug has no effect on weight. 
 H0: mean_weight_control - mean_weight_cases = 0 

 2.  Calculate probability of outcome if we assume null hypothesis 
is true: 
 What is probability of seeing a difference this size assuming the drug 

has no effect 
 If the drug has no effect, then the difference in mean weight is due to 

sampling variability (chance) 
 We can calculate the probability of observing the difference in means due to 

chance alone by calculating how much people randomly vary in our sample 
 If people do not randomly vary much, then a large difference between means is very unlikely if the 

drug has no effect 
 If people vary wildly by chance, then a large difference in means is possible by chance even if the 

drug has no effect 
 But becomes less probable as sample size increases 

 Assumptions allow us to calculate these probabilities 
 For instance, we might assume that weight is normally distributed 
 Before, assuming that the dice were fair allowed us to calculate the probability of the outcome 

 

HYPOTHESIS TEST RESEARCH EXAMPLE 



 3.  Assess null hypothesis in light of this probability 
 If the size of the difference is very unlikely if the drug has no effect, 

we reject the hypothesis that the drug has no effect 
 If the size of the difference is NOT unlikely (p-value > 0.05) if the 

drug has no effect, we fail to reject the null hypothesis that the drug 
has no effect 

 

HYPOTHESIS TEST RESEARCH EXAMPLE 



 Distribution of the outcome determines the type of statistical 
test to use 
 Continuous normally-distributed outcomes: 
 Do group means differ? 
 2 groups – t-test 
 3 or more groups – ANOVA and linear regression 

 Does this measurement predict the outcome? 
 Regression 

 Some departure from normality acceptable, especially with large samples 
 Large departures may require non-parametric tests 

 Categorical outcomes: 
 Do group proportions on outcomes differ? 
 Chi-square test of independence, logistic regression (binary outcome) 

 Does this measurement predict the outcome? 
 Logistic regression (binary outcome) 

 
 

WHAT TYPE OF TEST DO I USE? 



 A huge variety of methods to analyze data 
 Outcomes with the following properties may require more 

advanced or special methods 
 Correlated outcome 
 Repeated measurements 
 Clustering 

 Count outcomes 
 Time to event outcomes 

 Data with significant amount of missing or censoring may also 
require special methods 

 Link to table of outcomes and appropriate statistical test: 
 http://www.ats.ucla.edu/stat/spss/whatstat/ 

 

WHAT TYPE OF TEST DO I USE? 



 We use t-tests to assess whether 2 group means dif fer 
 Example: Do patients who take a proposed diet drug have a lower 

mean weight than those who take placebo? 
 Assumes outcome is normally distributed 

 We will test in SPSS whether males and females dif fer in their 
math achievement test scores 
 Analyze -> Compare Means -> Independent Samples t-test 
 Test Variable = outcome 
 Grouping variable = group 
 Must tell SPSS numerical values of groups to be compared 

 Use Paired Samples t-test if outcomes may be correlated 

T-TEST: DO 2 GROUPS MEANS DIFFER? 



T-TEST: DO 2 GROUPS MEANS DIFFER? 

 Males and females do not significantly dif fer in math scores 
 



T-TEST: DO 2 GROUPS MEANS DIFFER? 

 Typically 3 items are reported 
 t – a measure of the difference between means relative to their 

variability 
 df – the degrees of freedom, a measure of our effective sample size 
 p-value – probability of observing a t of this size, given the degrees of 

freedom (sample size) 
 SPSS output column Sig. (2-tailed) 

 t(198) = 0.413, p = 0.68 
 

 



T-TEST: DO 2 GROUPS MEANS DIFFER? 

 T-test assumes groups have equal variances 
 Levene’s Test assesses this assumption 
 If “Sig.” for Levene’s Test is < 0.05, consider using bottom row of 

results 
 Corrects for unequal variances 
 

 



 ANOVA compares means of several groups 
 Example: Do patients taking diet drugs A, B, and C have different 

mean body weight from each other and from controls? 
 T-test is special case of ANOVA 
 Assumes outcome normally distributed 
 And homogeneity of variance 

 We will test in SPSS whether three dif ferent programs dif fer 
on their writing test scores 
 Analyze -> General Linear Model -> Univariate 
 Dependent variable = outcome 
 Fixed Factor(s) = grouping variables 
 If you have more than one factor, use the Model window to specify which 

effects you want 
 Main effects vs interactions 

 
 

ANOVA – ARE THERE DIFFERENCES 
AMONG MANY GROUP MEANS? 



 The three SES classes dif fer 
in their writing score means 
 Known as an omnibus test 
 Tested before pairwise tests 

 Sometimes the entire 
ANOVA table reported 

 In text, usually report: 
 F – how much groups means 

differ relative to their 
variability 
 df – measure of effective 

sample size 
 Need df for ses (2) and df for 

Error (197) 
 p-value (Sig.) – probability of 

observing F this size under null 
hypothesis 
 F(2, 197) = 4.97, p = 0.008 

 
 

 

ANOVA OUTPUT 



Use Post Hoc 
window to perform 
pairwise comparison 
Tukey and 

Bonferroni are 
common 
adjustments 
High different from 

low and middle 
 
 

ANOVA: POST-HOC TESTS 



 Linear regression and ANOVA are equivalent methods 
 Use the same command in SPSS 

 Regression typically used to model ef fects of continuous 
predictors 
 Example: does resting heart rate predict weight? 

 Regression can also model categorical predictors, l ike ANOVA 
 We control for the effects of predictors by adding them to the 

regression model 
 If gender and age are in regression model, we interpret coefficient of 

gender as the effect of gender, after controlling for age 

LINEAR REGRESSION – DOES THIS 
MEASUREMENT PREDICT THE OUTCOME? 



 Let us model whether gender and reading test score predict 
writing test score 
 Analyze -> General Linear Model -> Univariate 
 Dependent variable = outcome 
 Fixed Factor(s) = categorical predictors (factors) 
 Covariate(s) = continuous predictors 

 Options Window -> Check Parameter Estimates 
 This outputs the regression table 

 Model Window 
 By default, SPSS will fully interact all factors (categorical predictors) in 

the model 
 But, you can specify exactly which main effects and interactions you want 

 Interactions model the effects of one variable changing with levels of the 
another variable 
 Example – the effect of weight on heart rate may differ between man and women 

 

LINEAR REGRESSION IN SPSS 



Regression coefficients: 
change in outcome per 
unit-change in predictor 

For each unit increase 
in reading score, writing 
score increases by .566, 
after controlling for 
gender 

Males(female=0) on 
average score 5.487 
lower on writing, after 
controlling for reading 
score 

LINEAR REGRESSION OUTPUT 



For each effect, report: 
B coefficient – 

magnitude of effect 
Std. Error or t –provide 

same info 
p-value (Sig.) - 

probability of observing 
B coefficient of this size 
relative to its standard 
error 

LINEAR REGRESSION REPORTING 



 Used to see if 2 categorical variables are associated 
 Are the proportions across levels of one variable the 

same across levels of the other variable? 
 Are the proportions that fall within each BMI category the 

same for patients with Type I vs Type II diabetes?  
 Let’s test whether the proportions within each school 

program type are the same across genders 
 Analyze -> Descriptives -> Frequencies 
 Statistics Window -> Check Chi-square 

 
 

CHI-SQUARE TEST OF INDEPENDENCE 



 Let’s test whether the proportions within each school 
program type are the same across genders 

 Analyze -> Descriptives -> Crosstabs 
 Rows(s) – 1 categorical variable here 
 Column(s) – 1 categorical variable here 
 Layer 1 of 1 – Any additional categorical variables to test for 

association 
 Can test 3- or more-way association 

 Statistics Window -> Check Chi-square 
 

CHI-SQUARE TEST OF INDEPENDENCE IN 
SPSS 



CHI-SQUARE TEST OF INDEPENDENCE 
OUTPUT 

 Gender and program type 
not associated 

 Typically report: 
 Chi-square – measures how 

much observed proportions 
differ from proportions 
expected if variables are not 
associated 
 df – (number of rows-

1)*(number of columns-1) 
 P-value (Asymp. Sig.) – 

probability of observing this 
chi-square with these df 
 χ2(2) = .053, p = .974 

 



 Used when analyzing what predicts a binary outcome 
 Binary = 0/1, yes/no 

 More specifically, we are modeling what affects the odds of 
the outcome 
 Let p = probability that outcome = 1 
 Odds(p) = p/(1-p) 
 So, if p = .5, odds = .5/.5 = 1 
 If p = .75, odds = .75/.25 = 3 

 Example – are gender and age predictive of the odds of 
developing Parkinson’s disease? 
 

LOGISTIC REGRESSION 



 Let’s see if gender and math score predict the membership to an 
honors program (1 = in honors, 0 = not) 

 Analyze -> Generalized Linear Models -> Generalized Linear 
Models  
 Type of Model tab 
 Choose Binary logistic 

 Response tab 
 Dependent variable = move binary outcome here 
 Click Reference Category button 
 Choose First(lowest value) 
 Will model odds outcome = 1 

 Predictors tab 
 Factors – categorical predictors 
 Covariates – continuous predictors 

 Model tab 
 Choose which main effects and interactions you want 

 Above is the minimum specification for logistic regression 
 To get odds ratios reported 
 Statistics tab 
 Check Include exponential parameter estimates 

LOGISTIC REGRESSION IN SPSS 



 OR=1 : no dif f , OR<1:  Lower Odds, OR>1:  Higher Odds 
 Being male decreases the odds of being in the honors 

program by 68.4%  
 1 – Exp(B) for female = 0 

 Each point increase in math score increases odds of being in 
honors by 20% 
 Exp(B) – 1 for math 
   

 

LOGISTIC REGRESSION OUTPUT 



 Typically report 
 Coefficient = B 
 Odds ratios – Exp(B), the factor by which the odds of the outcome 

change per unit change in the predictor 
 Std. Error – variability in coefficient 
 Chi-square and df – used to test coefficient 
 p-value – Sig., probability of observing chi-square 
 Often report confidence interval on odds ratio 
 B = -1.21, S.E. = .424, Odds ratio = .326, χ2(1)=.008 
   

 

LOGISTIC REGRESSION OUTPUT 



Data analysis examples 
How to conduct more advanced analyses 
http://www.ats.ucla.edu/stat/dae/ 

Annotated output 
How to read output 
http://www.ats.ucla.edu/stat/AnnotatedOutput/ 

Web seminars for SPSS 
More detailed guides 
http://www.ats.ucla.edu/stat/seminars/#SPSS 

 

ADDITIONAL RESOURCES 

http://www.ats.ucla.edu/stat/dae/
http://www.ats.ucla.edu/stat/AnnotatedOutput/
http://www.ats.ucla.edu/stat/seminars/#SPSS
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